网站首页 » CMS » 其它 » WIN7 升级到 WIN10 后 wamp 启动变橙色、页面空白及 Forbidden解决方法
上一篇:
下一篇:

WIN7 升级到 WIN10 后 wamp 启动变橙色、页面空白及 Forbidden解决方法

从WIN7升级到WIN10后,wampServer启动出错了,没法使用。

具体问题:任务栏里的启动图标变橙色了,而不是绿色。地址栏输入localhost或者127.0.0.1访问,页面竟然是空白的。首先我们先解决图标变橙色的问题。

出现这个问题其实是由于你的80端口被占用的原因。找到目录D:\wamp\bin\apache\Apache2.2.21\conf文件夹里的httpd.conf文件,ctrl + F 查找 80,把所有的80换成8080或者你喜欢的端口就行了。替换完后保存文件,重启wampServer。图标 应该会变成绿色了。

当我再输入localhost:8080后,页面竟然显示

You don’t have permission to access / on this server.

行是再找到D:\wamp\bin\apache\Apache2.2.21\conf文件夹里的httpd.conf文件,找到

<Directory />
 Options FollowSymLinks
 AllowOverride None
 Order deny,allow
 Deny from all
</Directory>

修改成

<Directory />
 Options FollowSymLinks
 AllowOverride None
 Order deny,allow
 Allow from all
</Directory>

还需要修改一个地方

# onlineoffline tag - don't remove
Order Deny,Allow
Deny from all 
Allow from 127.0.0.1

把上面的 Deny from all 修改成 Allow from all。当我再次输入localhost:8080时竟然可以正常访问了。

这里有一个地方不太确定就是第一次安装wampServer时是在D盘的,经过多次尝试都没解决问题,于是我就重装把它安装到C盘下。重复上面的步骤问题就在不经意中解决了。所有不知道是不是路径一定要安装在C盘才可以。大家可以试试。

晚上回来又安装了一次wampServer得出的结论是安装在C盘还是安装在D盘,其实都没什么区别,都是可以访问了。那么为什么通过localhost或者127.0.0.1访问时会是空白页呢?其实很简单,我们忘记在localhost或者127.0.0.1后面添加端口号:8080。因为我们之前修改了默认的端口号80。不信你试试,应该可以正常访问了。

想了解更多关于wampServer问题不妨阅读下这篇文章《wamp server多站点配置不加localhost》

  • 微信扫一扫,赏我

  • 支付宝扫一扫,赏我

声明

原创文章,不经本站同意,不得以任何形式转载,如有不便,请多多包涵!

本文永久链接:http://yunkus.com/wampserver-win10-orange-blank-forbidden-solution/

Leave a Reply

Your email address will not be published. Required fields are marked *

评论 END